Vent lidt med at opdatere til WordPress 5.0

Vent lidt med at opdatere til WordPress 5.0

Den nye version af WordPress (version 5.0) kommer ud nu, men vi anbefaler kraftigt at vente med at opdatere indtil januar.

Hvad sker i WordPress 5.0?

Først og fremmest handler det om den nye editor. I stedet for den velkendte teksteditor kommer den nye WordPress som standard med en blokbaseret editor kaldet Gutenberg

Du kan se mere om det i de tidligere indlæg om WP5.0 og Gutenberg.

Er det kompatibelt med mine plugins og tema?

Udviklerne har haft lang tid til at tilpasse og håndtere disse ændringer – desværre har mange brugt tiden på at brokke sig over denne udvikling i stedet for at få deres kodet opdateret og gjort kompatibelt med Gutenberg.

Du kan dog slå denne editor fra ved at installere plugin’et Classic Editor, men det er sikkert at det er nok. Der ligger stadig en del ændringer længere ned i koden.

Denne ændring har mange konsekvenser og det lader til, at ikke alle udviklere af plugins og temaer har fulgt med. 

Du risikerer altså at dit websted ikke længere fungere 100% efter en opdatering.

Ikke en automatisk opdatering

Den nye WordPress er en ‘major upgrade’. Det betyder, at det med en standardopsætning ikke vil blive installeret automatisk ( – jeg giver ingen garantier!). Men du vil stadig få at vide at den ligger og venter.

Hvis du vil være helt sikker kan du indsætte linjen

define( 'WP_AUTO_UPDATE_CORE', false )

i din wp-config.php.

Du kan læse mere om den funktion i WordPress Codex

Hvornår skal du så opdatere?

December er ferieperiode for rigtigt mange. Det betyder, at der ikke vil blive gennemført nær så mange tests som på andre tider af året. Og julen vil stå i vejen for en stor del af udviklingen og tilpasningen af mange plugins. Programmører holder jo også ferie.

Så personligt regner jeg med at vente til begyndelsen af januar før jeg afprøver WP 5.0 på andet end test-websteder. Og det vil jeg også anbefale du gør.

Jeg tager chancen!

Hvis du insisterer på at ville installere den nye version – og så farligt er det altså heller ikke – så er her en hurtig guide til det:

Guide til installation af større opdatering af WordPress

  1. Sørg for at alle plugins er opdaterede

    Opdater alle plugins til seneste version. Og tag et hurtigt tjek på alle, du ikke kan huske at have opdateret for nylig, om hvor gammel den seneste version er. Kig i WordPress plugin biblioteket, der kan du se seneste opdatering. Er det mere end et par måneder siden, er der forhøjet risiko. Screenshot fra WordPress plugin bibliotek af forældet plugin

  2. Sørg for at dit tema er opdateret

    Det samme som for plugins.

  3. Tag en backup

    Altid huske, aldrig glemme – at gemme! 
    Det er standard for enhver opdatering og bør ikke komme som en overraskelse for dig.

  4. Installer evt. Classic Editor

    Find dette plugin og installer det. Så vil Gutenberg ikke blive aktiveret og du kan fortsætte med den gamle teksteditor. Det mindsker risikoen betragteligt

  5. Opgrader

    Du kender proceduren…

  6. Test

  7. Gendan evt. fra backup

    Hvis ikke det virkede, så har du din backup fra pkt. 3 at falde tilbage på.

Skriv en kommentar

This site uses Akismet to reduce spam. Learn how your comment data is processed.